open mini netbook

open project of mini netbook, 7'' ARM netbook


You are not connected. Please login or register

Netbook problemas Fail to init USB BurnTool

Go to page : 1, 2  Next

View previous topic View next topic Go down  Message [Page 1 of 2]

jciral


Hola.
Soy nuevo aquí.
Quisiera hacer una consulta.
Tengo un netbook con chip AK8802 y se ha quedado pillado en la pantalla de arranque (wireless Book).
Llevo 2 días buscando información para resolver el problema pero no puedo hacer nada.
He probado todo diferentes BurnTool el firmware 182, 186 ………
Tengo reconocido el m3chip en el puerto USB.
No hay manera me da error USB, ya he leído y algunos lo han solucionado pero yo no he podido.
Pido alguna sugerencia o ayuda para rescatar mi netbook.
Gracias.
Saludos.

esteban_palacios


estamos iguales pudiste solucionar algo me recoce el hardware pero no se conecta burntool

Oto


Master
Master
Known problem for ak8802 as it is not compatible with ak78xx burn tool.

There is one thing you could try. From archive "zt-n760_with_ANKY.rar" (link) connect to USB and short DL_JUMPER, start the program DEMO\880xDownLoadTool\akubhost.exe with parameters "AKUBHOST.exe /init:cfg_pll248M.txt /down:ASPEN3_BIOS_TEST.bin /down_addr:0x33e00000 /go". After that netbook will wait for next commands(jumper must be shorted all times) and then try to run burntool.

AKUBHOST = Anyka AK USB BOOT HOST

esteban_palacios


thank you otoluk
try install
the next comment
if I was good or not

esteban_palacios


the usb init ok but init chip faild
screen of the cmd
[You must be registered and logged in to see this image.]

other solution?

Oto


Master
Master
Ok, Then try "/init ddr_8801_cfg_micron_124-248.txt"

abrgranadilla


Hola, estoy en la misma situación, he hecho todo esto que decis, me sale incluso Init chip ok, todo me sale ok con el akubhost, pero si luego uso el burn tool, se queda en init usb fail, aunque si desconecto y vuelvo a conectar el cable usb, me pasa de ahi y pone start to test y no hace nada mas, y hasta ahi he llegado... alguien ha avanzado un poco mas?

jciral


Hola.
Como nadie respondia ya tenia un poco olvidado.
He hecho varias pruebas y en algunas de ellas cuando despues de ini le doy a go y parace que me esta cargando la rom.
Pero al final me desaparece la pantalla y tambien me desaparece en ini.
Voy a seguir haciendo pruebas con todas los posibles configuraciones que hay.
Tambien me gustaria conseguir la rom de wince 6.0 para AK8802.
Ya lo he intentado con una de las AK7802 pero sin exito.
Si consigo algo ya comentare, Si alguien a conseguido revivir su Netbook espero que comente como lo ha conseguido.
Gracias por la informacion.
Saludos.

esteban_palacios


use all txt files and does not work with any

probe con todos los txt y no funciono ninguno

use the burn tool again, usb init ok but at the beginning of the load, it appears:

use el burn tool de nuevo, el usb inicia pero al comenzar la carga aparece esto:


[You must be registered and logged in to see this image.]

Oto


Master
Master
So nothing changes if using akubhost or not? right? And all txt ends with initchip faild for akubhost?

Think that "Fail to set registers" = Initchip faild

abrgranadilla


Importará que este usando el win 7, lo mismo es necesario xp?

estoy igual que tu esteban_palacios

jciral


Hola.
Yo he estado haciendo pruebas y tengo el mismo error.
tengo el XP me da los mismos errores.
Creo que lo que necesitamos es la rom para AK8802.
Saludos.

esteban_palacios


es imposible encontrar el rom para el 8802 alguien sabe si estos aparatitos arrancan de la memoria sd, el mio no. lei en agunos lados que apretando F1 se puede cambiar el arranque a la sd, pero tampoco funciona. alguien tiene idea de porque no?

gracias

esteban

Oto


Master
Master
Doesn't the ak8802 have the Upgrade F1 option?

pernieda


Compañeros estoy en la misma situacion desde diciembre que me llego este dichoso anyka ak8802.
No hay nada para este chip en ningun sitio.
Por favor ayudadme si encontrais algo.
Si saben algo publiquenlo gracias

Oto


Master
Master
Does running the AK8801_MI_84M_CL2_03.exe demo tool and clicking "setvalue" work?

jciral


Hola.
He realizado lo que comentas y este es el resultado.
----------------------------------------------------
Hello.
I've done what you mention and this is the result.
[You must be registered and logged in to see this image.]

Parece que si hace algo.
-------------------------
It seems that if you do something.
-----------------------------------
También se puede observar que instala un boot del pack 182 del burntool.
------------------------------------------------------------------------
You can also install a boot to note that 182 of burntool pack.
[You must be registered and logged in to see this image.]

Pero no soluciona nada en el netbook, sigue sin arrancar.
---------------------------------------------------------
But does not solve the netbook, still does not start.


Por favor cualquier cosa comentarlas para hacer pruebas.
Gracias.
--------------------------------------------------------
Please comment on anything for testing.
Thanks.



Last edited by jciral on Sun 20 Feb 2011 - 1:36; edited 1 time in total

Oto


Master
Master
Great then it should be possible to upgrade using burntool. I think I now know where is the problem.

Ok, one thing what you could try:
1. Run AK8801_MI_84M_CL2_03.exe
2. Setvalue
3. Click "Download" and then choose the 1.9 ROM eboot.
4. Click "Go"

What it does is uploads eboot to RAM and then executes, so we will know if 1.9 ROM will work on ak88 or not.



Last edited by Oto on Mon 18 Feb 2013 - 8:57; edited 1 time in total

jciral


Hello.
I loaded the 1.90 EBOOT to AK8801_MI_84M_CL2_03.exe
Then I tried to burntool and continues with the same error (Fail to init USB)
Otoluk, thanks for your help.
Greetings.

Oto


Master
Master
But it didn't boot(start) by itself after clicking "GO"? That's bad because burntool will not help if eboot doesn't run.

Does this work? Please post results?
Code:
UINT  reg_addr[] = {
0x080000dc,
0x08000004,
0x66668888,
0x2002d004,
0x2002d000,
0x2002d000,
0x2002d000,
0x66668888,
0x2002d000,
0x2002d000,
0x2002d000,
0x66668888};


UINT reg_value[] = {
0x0000100c,
0x00021067,
0x000000c8,
0x09527214,
0xe0170000,
0xe0120400,
0xe0100033,
0x000000c8,
0xe0124400,
0xe0110000,
0xe0110000,
0x00000000};

jciral


Otoluk, I will explain the process step by step I make.
Maybe I'm doing something wrong.
1. Connect the netbook PC.
2. I open the AK8801_MI_84M_CL2_03.exe
3. click on (SetValue) in a few seconds the message (set value finish!)
4. click on (OPEN) select the file eboot.nb0
5. click on (Download) and another sale appears with the message (Go From Address (HEX) 30038000) click on OK and displays the screen showing the red line of writing, but at the end gives no message.
6. I close the AK8801_MI_84M_CL2_03.exe and disconnect the Netbook.
7. Selected burntool open the firmware I want to install (Pack 1.90) connect the netbook, Device0 automatically selected in yellow.
8. Click on Start and Fail to init USB error
The process of writing the Eboot I can not do it directly from (Go) I have to start from (download), because in (Go) does nothing, it shows the same screen (download)
Click on (Ok) and does nothing.
Another thing, as I test the settings as sent.
It is for the burntool or AK8801_MI_84M_CL2_03.
And as I do.
Thanks.
Greetings.
-------------------------------------------------------------
Otoluk, te voy a explicar el proceso que hago paso a paso.
Quizás estoy cometiendo algún error.
1. Conecto el netbook al PC.
2. Abro el AK8801_MI_84M_CL2_03.exe
3. click sobre (Setvalue) en unos segundos aparece el mensaje (set value finish!)
4. click en (OPEN) selecciono el archivo eboot.nb0
5. click sobre (Download) y aparece otra venta con el mensaje (Go From Address (HEX) 30038000) click sobre OK y se muestra la pantalla donde se muestra la línea roja de escritura, pero al terminar no da ningún mensaje.
6. Cierro el AK8801_MI_84M_CL2_03.exe y desconecto el Netbook.
7. Abro el burntool selecciono el firmware que quiero instalar (Pack 1.90) conecto el netbook, automáticamente se selecciona Device0 en color amarillo.
8. Click en Start y error Fail to init USB
El proceso de escribir el Eboot no puedo hacerlo directamente desde (Go) tengo que hacerlo desde (download), porque en (Go) no hace nada, muestra la misma pantalla que (download )
Click en (Ok) y no hace nada.
Otra cosa, como pruebo la configuración que as enviado.
Es para el burntool o AK8801_MI_84M_CL2_03.
Y como lo hago.
Gracias.
Saludos.
[You must be registered and logged in to see this image.]

Oto


Master
Master
AK8801_MI_84M_CL2_03 won't help you to run burntool as burntool sets the registers values again by itself. We use AK8801_MI_84M_CL2_03 to find the right settings for burntool.

1. Regarding the values
Code:
I posted, these are for AKUBHOST. Copy the values in a text file(for example ak88.txt) and use "AKUBHOST.exe /init:ak88.txt". Post the results it should say "initchip OK"



Last edited by otoluk on Tue 22 Feb 2011 - 20:56; edited 1 time in total

jciral


This is the result:
I have to say that when I open the application (INIT) or (Go) opens the window and in less than 2 seconds away.
I do not know because I have this problem.
The image I managed to capture the screen, I had to do more than 20 attempts to get that image.
-----------------------------------------------------------------------------------------------
Este es el resultado:
Tengo que decir que cuando abro la aplicación (INIT) o (Go) se abre la ventana y en menos de 2 segundos desaparece.
No sé porque tengo este problema.
La imagen la he conseguido capturando la pantalla, he tenido que realizar más de 20 intentos hasta conseguir esa imagen.

[You must be registered and logged in to see this image.]

Oto


Master
Master
It shouldn't close. Just run CMD and then akubhost, it will remain open. Very Happy

Ok. The values now work.

Now try my hexedited tool!

jciral


I've been able to do the tests as I said to (Run / CMD)
The burntool still does not work, maybe we should put the eboot in a specified address position to make it work.
The burntool used is that as amended.
I put some pictures of the evidence.
Please Otoluk any suggestion or evidence or whatever it takes, tell me what to do the testing.
Thanks for your help.
-------------------------------------------------------------------------------

Ya he podido hacer las pruebas bien, como decías con (Ejecutar/CMD)
El burntool todavía no funciona, quizás hay que poner el eboot en alguna posición address especifica para que lo haga funcionar.
El burntool utilizado es el que as modificado.
Pongo algunas imágenes de las pruebas.
Por favor, Otoluk cualquier otra sugerencia o pruebas o lo que haga falta, dime lo para hacer las pruebas necesarias.
Gracias por tu ayuda.

[You must be registered and logged in to see this image.]

[You must be registered and logged in to see this image.]

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 2]

Go to page : 1, 2  Next

Permissions in this forum:
You cannot reply to topics in this forum